28 May 2019

No response from the MSG, PRE and ATTN keys on Elecraft KX3 - solution


No response from the MSG, PRE and ATTN keys when either press or hold them on Elecraft KX3

Petr Ourednik, OK1RP, ok1rp@fastmail.com.au

 
Some KX3 users found that 3 buttons on their KX3 stopped working. They get no response from the MSG, PRE and ATTN keys when they either press or hold them.

If you know that your MSG and PRE keys were working earlier when you set up a voice message to send your call sign and now no responding anymore > ON/OFF did not helped and rest of buttons tested and works well… here is the way how to fix the issue on your KX3 radio. 


1. Remove all cables and use some ESD protection tools on bench (at least discharge themself to grounding point)



2. Unscrew four main thumb screw and open the KX3 carefully

3. In the middle you will find flat (like PC) flex cable (we say ribbon cable) conecting both sides together



4. Even although it seems that on both sides the flex cable is seating well in > remove it carefully on both sides. You will have two parts of KX3 > still connected together with battery cable (if installed as shown on Page 41, Fig. 62 of manual) + the flex cables on the table. If the battery opt. is not installed then you will have two separated KX3 parts + ribbon cable on the table. See the page 40, 41 of the manual here: https://ftp.elecraft.com/KX3/Manuals%20Downloads/E740164%20KX3%20Kit%20Assembly%20Manual.pdf

 


5. Clean the pins in PCB with isopropylalcohol and blow out dust residues in connectors on the flex cable  

6. Re-seat/instal the flex cable back to KX3 carefully. Be sure that the ribbon cable is oriented with the long tab toward the speaker and all pins are engaged when you will put it back to your radio. See Fig.61 on Page 41 of the manual here: https://ftp.elecraft.com/KX3/Manuals%20Downloads/E740164%20KX3%20Kit%20Assembly%20Manual.pdf


 
7. Check again that flex cable seats well fully engaged and there is nothing forgoten inside of KX3.

8. Close the top and bottom covers of your KX3 carefully and secure them with thumb screws.
 

CAUTION: As you close the covers ensure that the flex cable folds into the space next to the CP board connector as shown. Do not allow it to fold toward the battery holders. If the flex cable resists pushing into the space next to the CP board connector, use your finger to gently crease it along the edge of the connector as shown in Figure 61 of the manual.

 



9. Turn on KX3 and enjoy with all buttons functioning again... :)

NOTE 1: As the ribbon cable had to be re-seated in this procedure > if you have clean pressed air available with few bars pressure and fairly dried (-83deg C dew-point in my case) I am recommending clean the connectors carefully on the ribbon cable using the pressed air to blow-up the dust residues before installing it back.

NOTE 2: If you have the similar symptoms (MSG, PRE and ATTN buttons issue) on your KX3 then try this repairing procedure first before more complicated actions like hard-reset to factory defaults or so. It is easy and can help in few minutes.


NOTE 3: I should note that the ribbon cable is not loose when you will open your KX3. You will find that it is fully inserted. Even although you will pull it out, clean and push it back in and things will start working.

Hope it helps.

 
73 - Petr, OK1RP
"Apple & Elecraft freak"
B:http://ok1rp.blogspot.com
MeWe: https://bit.ly/2HGPoDx
MeWe: https://bit.ly/2FmwvDt

 

Repairing document done by P. Ourednik, 28-May-2019. Document 05-19, rev.1.0

1 comment:

  1. Hi all, in reply to few emails I am sharing over here > yes I compiled this guide to .pdf file and it is available upon email request.

    ReplyDelete